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Welcome To Intaglio

About this guide
This guide describes the features of Intaglio and explains how to use them.

Note: this guide frequently refers to menu commands.  These commands are 
specified like this:

Choose Layout > Zoom > Zoom To Fit

The example above starts with the Layout menu in the menu bar, selects the 
Zoom submenu, and finally chooses the Zoom To Fit menu item as shown 
below.

A similar method is used to specify the location of a file or folder on the 
computer’s hard disk.  For example:

Home > Library > Application Support > Intaglio

specifies the Intaglio folder within the Application Support folder within the 
Library folder within the current user’s home directory.

Onscreen help
To use Intaglio’s onscreen help choose Help > Intaglio Help.  The onscreen help 
system describes the function of each menu item and window, and contains 
instructions for basic drawing functions.  You can browse the help system from 
the main page or search for specific terms.  The help files are also available 
online at:


  www.PurgatoryDesign.com/Intaglio/Help/Intaglio Help.html.
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Intaglio Overview

About Intaglio
Intaglio is a graphics application designed specifically for Mac OS X.  Because 
of this narrow focus, Intaglio is able to make the most of the powerful graphics 
technologies Apple is creating for the Macintosh such as Quartz and CoreImage.

Software for 2D graphics work can be divided into two categories.  The first 
category is software to create and edit bitmap images such as digital 
photographs.  The second category is software to create and edit vector images 
such as text and abstract shapes.  Software in one of these categories is 
frequently called either a paint or a draw application respectively.  Each type of 
graphics application is useful for different kinds of tasks.

By the definition above, Intaglio is a drawing application.  It manipulates graphic 
elements as individual objects (i.e., vectors).  For example, text created in 
Intaglio is saved as characters in a particular font and can be edited easily, 
whereas text saved in a paint program is generally just pixels in a bitmap so it is 
hard to edit.  Graphic objects such as lines and rectangles are all examples of a 
basic drawing element called a path.  Paths are arbitrary shapes whose interiors 
can be filled and whose outlines can be stroked.  Intaglio also works with bitmap 
images such as digital photos as objects.  These images can be manipulated in 
a manner similar to any other graphics object but the individual pixels in the 
image can’t be edited.

Intaglio bridges the gap between bitmap and vector graphics with a set of 
powerful special effect filters.  This allows bitmap style operations to be 
performed on vector graphics while maintaining the ability to edit the graphics in 
vector form and modify the settings used to create the effects.

System requirements
Intaglio requires Mac OS X 10.2 or later and will take full advantage of the 
graphics features in 10.3 and 10.4.  Some features require these later versions of 
the OS and may work best with the graphics hardware (i.e., the video card) 
Apple has specified to work with CoreImage.

Intaglio Overview
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The document window

Customize the toolbar to contain the tools you use most often.  

Drag guides into the drawing 

area from here.

!

Drag the ruler origin from here (option-click to set it numerically).

The annunciator displays information about the selected graphics.

Set the grid and drawing 

measurements to assist you 

when drawing to scale.

The magnification control allows you to zoom the drawing in 

or out from the document window.

The document window is where drawing takes place.  You can also drag a 
graphic directly into the window to add it to the drawing (see page 7).  

The drawing area in the document window shows only the printable area of the 
page.  Most printers will also add a blank margin around the drawing area of the 
page.  To see what the page will look like when printed choose File > Print and 
select the Preview button.

Intaglio Overview
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The inspector panels
You can open the inspector panels from the Window menu and in some cases 
other menus as well.  Each panel contains controls for a related group of 
functions.  For example the Fill inspector controls the fill mode and color of path 
and text graphic objects.  To open the fill inspector choose Window > Fill.

You can reduce the size of an inspector by clicking the mouse in the disclosure 
triangle in its top left corner next to the inspector’s title.

You can group inspector panels together in any combination you choose by 
dragging the inspector by the area around its title at the top of the panel.

Drag this area to 

combine inspectors.

Some inspectors have a disclosure triangle in the lower right corner to reveal 
extra controls that are generally used less often than the others.  For example, 
the stroke inspector normally hides the controls for things like arrows and dash 
settings.  To reveal these extra controls just click the mouse in the triangle at the 
bottom of the panel.

Intaglio Overview
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Click the triangle in the lower right 

corner to reveal extra controls.

The tool palette

The tool palette contains all of the tools you use for drawing.  In the tool 
preferences, you can orient this palette either vertically or horizontally depending 
on how you prefer to organize your workspace.  If you hold the cursor 
motionless above a tool button for a couple of seconds a help tag will appear to 
give you the name of the tool and the its shortcut character.  If you press the 
command (⌘) key on the keyboard, this help tag will change to provide a 
description of the tool.

The individual tools are described later in this guide.

Intaglio Overview
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The toolbar

When you first launch Intaglio the toolbar at the top of the document window will 
contain tools to set fill and stroke properties, perform graphic transformations, 
and open the Geometry inspector to edit an object’s size and location.  You can 
use the Customize tool on the right end of the toolbar to rearrange these tools or 
replace them with others you find more useful.  As is described above for the 
tool palette, holding the cursor motionless above a tool icon in the toolbar will 
display a help tag with the name of the tool.

The tools in the toolbar fall into these categories:

Fill

Sets the fill color or pattern of selected paths and text blocks.

Stroke

Sets the stroke properties of selected paths and text blocks.

Transformation

Performs graphic transformations such as rotate, shear and flip on the selected 
graphics.

Miscellaneous
Various other convenience operations such as printing, opening palettes, and 
controlling layers and scripts.

Intaglio Overview
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Drag and drop
When working on a drawing you may want to include graphics from another 
application or export your work to another application such as a word processor 
or web site design tool.  Frequently the easiest way to do this is via the standard 
Macintosh process known as drag and drop.

To import a graphic into Intaglio you can usually just drag it directly into the 
document window.  Graphic types you can import this way include PDF vector 
graphics and bitmap images in various formats.  You can drag the files 
containing these graphics into Intaglio from the Finder or you can drag the 
graphics directly from other applications that support this capability.

When you drag a graphic object within the document window you’re usually just 
moving the graphic within the drawing, but you can also move a copy of the 
graphic by holding down the option key on the keyboard before you start 
dragging.  To make a copy that you can drag outside of the drawing hold down 
both the command (⌘) and option keys on the keyboard before you start 
dragging or just click the mouse on the graphic and hold it motionless for a 
short time (this can be done even when Intaglio isn’t the active application).  
When the cursor changes to a copy cursor (an arrow with a green ball containing 
a plus sign) you’re ready to drag the graphic to another window in Intaglio or 
another application.  You can cancel this drag at any time by pressing the 
escape (esc) key on the keyboard or dragging the graphic to the menu bar at the 
top of the screen.

The Library inspector (choose Window > Library) provides a place for you to store 
collections of graphics to reuse later.  To add a graphic to the Library just drag it 
into the Library window.  When you quit Intaglio all the graphics in the Library 
will be saved automatically.  To copy a graphic from the Library into a drawing 
just drag it from the Library window to the drawing.  You can permanently 
remove a graphic from the Library by dragging it to the trash in the Mac OS X 
dock.

Intaglio Overview
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Another way to save graphics for later reuse is by dragging them to a Finder 
window.  When you do this the Finder will create a clipping file that you can drag 
back into Intaglio later to copy the original graphic into a drawing (or the 
Library).  The Extras folder included with Intaglio includes a collection of clipping 
files containing sample shapes and patterns.

A Finder clipping file.

In addition to graphics you can also drag and drop colors in Intaglio.  The 
standard control for color editing in Intaglio is the color well as shown below as 
part of the Fill toolbar tool.

You can click in a color well to open the standard Mac OS X color picker, or hold 
down the option key when clicking to open Intaglio’s color inspector.  In addition 
to clicking on a color well to change its color you can drag a color from one well 
to another, or from a color well to the Library or a Finder clipping file.  You can 
create a pattern by dragging one or more graphics into a color well, and finally, 
dragging a color to a document window sets the color of all selected graphics in 
that window.

Intaglio Overview
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Document Setup

Drawing size
A new drawing automatically adopts the size of the current printer page when 
the drawing is created.  If this isn’t the size you want, you can change the paper 
size by choosing File > Page Setup and selecting a new size from the Paper Size 
popup menu or changing the page Orientation.  You can also create custom 
paper sizes to get an exact document size, however since Intaglio isn’t a bitmap 
editor you generally don’t need custom drawing sizes.  Instead you can just 
export an image at the size you need.

A drawing is generally a single page, but you can create larger drawings that 
span multiple pages by choosing Layout > Drawing Size.  This expands the 
drawing into a single large area with pages placed side by side.  To see where 
the edges of each page will fall when printing choose Layout > Show Page Breaks.

Color space
Intaglio uses Apple’s ColorSync technology to match the colors on the screen to 
the colors on the printer.  When a new drawing is created it automatically adopts 
the color space of the current printer as its default color space.  The default 
color space is applied to the colors used by new graphics when they are added 
to a document for the first time.  If you prefer new documents to use a specific 
default color space (e.g., RGB instead of CMYK) you can change this in the 
document preferences.  You can also change the default color space and the 
color profile used for each color space in an individual drawing by choosing 
Layout > Color Space.

Export & effects resolution
Whenever Intaglio exports a bitmap image or creates one for a special effect it 
uses the drawing’s export resolution.  The default export resolution is the same 
as the standard Macintosh screen resolution—72 dots per inch.  You can 
change the export resolution of the current drawing or change the export 
resolution of all new drawings by choosing Layout > Resolution.

Document Setup
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Drawing scale & units
Intaglio allows you to create scaled drawings in much the same way as a CAD 
system (although not with as many options).  You can set a drawing to convert 
one set of units on screen into something else in the drawing.  For example 
perhaps you want ¼ inch in your drawing to represent one foot in the real world.  
In this case you can enter the sizes of objects and add dimensions in feet and 
let Intaglio convert those final measurements into the correct values in your 
drawing.  Suppose you want one centimeter on your printed drawing to 
represent ten meters in the real world.  To set your drawing this way choose 
Layout > Measurements, set the Units popup to Meters and set the Scale to 
convert 1 Centimeter to 10 Meters as shown below.

You can create up to eight different scale and unit combinations within each 
drawing.  To switch from one set to the next, hold down the option key on the 
keyboard and click the mouse in one of the drawing’s rulers.  To show the rulers 
in a drawing choose Layout > Show Rulers.

Dimension text
If you’ve set the drawing scale and units in the section above you may want to 
let Intaglio calculate the length of lines and automatically add text to your 
drawing to indicate that value.  Any lines added to a drawing with the Dimension 
Tool (see page 18) will automatically add text to the drawing using the drawing’s 
dimension options.  These options include the font and size of the text, its 
format, and its position in the drawing in relation to the dimension line.  To 
continue the example above where 1 centimeter represents 10 meters you’ll 
probably want your dimensions displayed in meters using decimal fractions.  
Assuming you want the text to display the units (i.e., meters) and use the 

Document Setup
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Geneva font with a size of 10 points, you would choose Layout > Dimensions and 
set the dialog controls as shown below.

Grid
The drawing grid is helpful for maintaining a perspective in your drawings and 
for aligning elements.  It can be used with or without an automatic snap to the 
grid line intersections.  If you’ve set the drawing scale and units in the section 
above the grid can be specified in the drawing’s final units.  Grid lines are never 
visible in any printed or exported form of the drawing.

To set the grid dimensions and color choose Layout > Set Grid.  To turn the grid 
snap on and off choose Layout > Snap To Grid.  The grid snap is independent from 
the grid’s visibility.  You can still snap to the grid when it is invisible or vice versa.  
To hide the grid choose Layout > Hide Grid.

In addition to the ability to snap to grid line intersections, you can also snap to 
the anchor points of a path.  To turn point snap on and off choose Layout > Snap 
To Points.

Guides
You can add horizontal and vertical guide lines to a drawing to help align 
graphics.  Graphics will snap to guides but the guide lines are never visible in 
any printed or exported form of the drawing.  To add a guide to a drawing, drag 
the mouse from one of the guide buttons (or rulers) in the document window out 
into the drawing area.

Document Setup
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Once you’ve added a guide to a drawing the edges and centers of graphics will 
snap to it as you drag the graphic past the guide.  Graphics will snap to guides 
whenever they are visible.  To hide all the guides in a drawing and disable guide 
snap choose Layout > Hide Guides.

The horizontal guide button.

The vertical guide button.

When you create a new drawing its guides are locked.  This means you can add 
new guides and they won’t get in your way when you’re trying to select 
graphics, but it also means you can’t move or delete existing guides individually.  
If you want to move or delete a guide choose Layout > Unlock Guides and drag the 
guide to a new location or off the edge of the drawing completely if you’re done 
with it.  You can remove all the guides from a drawing at any time by choosing 
Layout > Clear Guides.

Layers
As a drawing starts to become complex it can be very useful to split it into more 
than one layer.   A layer is simply a collection of graphics all drawn together.  All 
of the graphics in the first layer are drawn before those in the second layer and 
so on.  This means the graphics in the first layer appear under those in all 
succeeding layers.  A layer can be used simply for its organizational benefits but 
its real power comes from the ability to hide and lock individual layers.  A hidden 
layer is invisible in the drawing and is a good way to keep things out of the way 
to reduce clutter.  If you’re working on one section of a drawing it can be useful 
to hide the other sections so they’re not in your way.  Sometimes you want to be 
able to see certain graphics but not select them.  For example, you may have a 
colored background under your entire drawing that you want to see but not 
interact with.  In this case you can put the background graphics into a locked 
layer so they’re visible but can’t be selected when you click the mouse on them.

Layers can be managed through the Layer inspector (choose Window > Layers), 
the document window annunciator, or the optional layer management tool for 
the toolbar.

Document Setup
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The Layers inspector.

Mark this column to lock a layer.

Remove the mark in this column to hide a layer.

To change the name of a layer or specify the printing properties of a layer open 
the Layer Settings dialog.

Document Setup
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Drawing With Intaglio

Selecting graphics
To edit graphics in Intaglio you must first select them.  To select graphics you 
use the Selection tool in the Tool palette (see page 5):




Each selected graphic displays “handles” around its edges you can use to resize 
the graphic.

3 Selected Graphics

To select a graphic with the Selection tool you just click the mouse on it.  To 
select more graphics you can click on them one by one while holding down the 
shift key on the keyboard, or you can use the Selection tool to draw a rectangle 
around them.  Normally the Selection tool will select only the graphics you 
enclose completely with the rectangle.  If you hold down the option key on the 
keyboard, the Selection tool will select any graphic the rectangle overlaps.

Selecting multiple graphics with a rectangle.

Drawing With Intaglio
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Colors

In Intaglio a “color” used to draw a graphic can be a solid color, a gradient, or a 
pattern.  A solid color uses either the RGB (red, green, and blue), CMYK (cyan, 
magenta, yellow, and black), or Gray color space.  It will automatically use the 
drawing’s ColorSync profile for that color space (see page 9).  A gradient is a 
combination of two or more solid colors (see page 32).  A pattern in Intaglio can 
be any collection of graphic objects, not just a small bitmap image (see page 
33).

Solid Gradient Pattern

Graphic objects
There are three basic types of graphic objects in Intaglio—paths, text, and 
images.

Paths
A path is an abstract shape made up of any combination of lines, curves, and 
arcs.  A path may be anything from a simple line or rectangle to a giant blob with 
bumps and holes.  The inside area of a path must filled with a color (including 
gradients and patterns), or the outline of a path must be stroked with a color, or 
the path can be both filled and stroked.

Drawing With Intaglio
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Text
Text is a block of international characters and can be treated much like a path 
whose shape is defined by a font designer using the characters and size you 
have chosen.  Most of the time, text in a drawing is just ordinary paragraphs and 
labels, but text can also be treated as a graphic design element.  Like paths, text 
blocks must be either filled, stroked, or both.  Text usually follows a horizontal 
base line but it can be vertical or even follow the outline of a curved path.

Images
An image is any graphic you’ve imported into Intaglio.  Images can be imported 
from a wide variety of bitmap and vector file formats, or directly from another 
application using copy and paste or drag and drop.  The bitmap image formats 
Intaglio supports include PICT, TIFF, JPEG and many others.  The vector image 
formats Intaglio supports internally are PICT (vector), PDF, and EPS.  Intaglio 
also allows you to convert several vector formats into Intaglio graphics for 
editing.  These include SVG and ClarisDraw files.  These files are translated 
directly into Intaglio graphics rather than including them as an image object.  To 
open an SVG or ClarisDraw file in Intaglio choose File > Open and select the file.

Drawing With Intaglio
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Drawing paths
There are several tools in the Tool palette (see page 5) to create new paths.  All 
of these tools create path objects but each specializes in creating a different 
type of path.  However once you’ve created a path with any of these tools it isn’t 
really any different than a path created with any other tool.

Polygon Tool

Round Rectangle Tool

Square & Rectangle Tool

Line Tool

Path Tool

Freehand Tool

Bézier Curve Polygon Tool

Dimension Line Tool

Arc Tool

Circle & Oval Tool

Point selection tool
Once you’ve created a path you can edit its segments with the Point Selection 
tool:




When you select a path with this tool the control points of each of its segments 
are highlighted so you can select and edit each point.  The process of editing 
these points is virtually identical to the process of creating them using the Path 
tool (see page 20), with one addition.  To add to the end of an an existing path 
select the path, hold down the option key on the keyboard, and click the mouse 
on a path end point (or click and drag for a curve).

Drawing With Intaglio
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Scissors tool




Divides an existing path into two sub-paths within a compound path (see page 
24).  Just click the mouse on the point where you want to break the path.  To 
add a control point to a path without breaking it, hold down the option key on 
the keyboard as you click the mouse

Line tool
Draws a straight line.  To constrain the line to be horizontal or vertical hold down 
the shift key on the keyboard as you draw it.  To center the line at the point 
where you first clicked the mouse hold down the option key.

Dimension line tool
Draws a straight line with a text label indicating the length of the line.  This is 
useful for adding dimension lines to scale drawings.  The format of the label is 
determined by the drawing’s dimension settings (see page 10).  If you resize the 
line some time after creating it, the text label will be automatically updated to 
indicate the new length.  If you change the drawing’s scale or dimension settings 
the text label will also be updated.

Rectangle & oval tools
To constrain the path to a square or circle (versus a rectangle or oval) hold down 
the shift key on the keyboard as you draw it.  To center the path at the point 
where you first clicked the mouse hold down the option key as you draw.

Arc tool
Draws circular arcs.  This is a two step process.  First click the mouse and drag 
it to define the arc’s radius and start angle, then release the mouse and drag it 
again to define the arc’s end angle.  Hold down the option key on the keyboard 
during the second step to create a pie shape instead of a simple arc.

Step 1:        Step 2:  

Drawing With Intaglio
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Bézier Curve Polygon tool
Draws polygons whose sides are curves or straight lines.  This is easier to use 
but provides less control than the Path tool described below.  To create a vertex 
for a curved side just click the mouse button.   To create a vertex for a straight 
side hold down the option key on the keyboard while clicking the mouse button.

Polygon tool
Draws polygons with a fixed number of sides.  To fix a vertex or side at the top 
of the polygon hold down the shift key on the keyboard while drawing.  To swap 
the sides and vertices hold down the option key.  You can set the number of 
sides on the polygon to be drawn by double-clicking the mouse on the polygon 
tool icon in the Tool palette.

Round rectangle tool

Draws rectangles with arcs for corners.  The corners can be either convex or 
concave and the size of the corners can be adjusted by double-clicking the 
mouse on the Round Rectangle tool icon in the Tool palette.

Drawing With Intaglio
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Freehand tool

Draws a multi-segment line as you drag the mouse.  When you release the 
mouse button Intaglio smoothes the line you’ve drawn according to the current 
tool parameters.  You can adjust the smoothness of the line and the tolerance 
for its deviation from the original line by double-clicking the mouse on the 
Freehand tool icon in the Tool palette.  Depending on the tool settings the 
resulting path may be composed of straight line or curve segments.

Path tool
Creates simple or complex paths containing one or more straight lines and/or 
curves.  The path tool takes a little time to master, but with it you can create 
paths of virtually any shape.  For an easier way to create polygon shapes with 
straight or curved lines see the Beziér Curve Polygon tool described above.

To start a path at a point click and release the mouse button at that point.  To 
add a straight line segment click and release the mouse button to create the end 
point of the line.  For example, this line was created by clicking the mouse twice, 
once for each end point.

Drawing With Intaglio
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To add another line click again.

To close the path, place the cursor over the first point, hold down the option key 
on the keyboard, and click the mouse one more time.

To add a curve segment click and drag the mouse to create the end point of the 
curve. The point where you click the mouse button becomes the end point and 
the point where you release it becomes the first control point.  For example, this 
curve was created by clicking to create the start point, then clicking and 
dragging to create the curve point at the end.

Drawing With Intaglio
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To add another curve click again.

In the first image below, the control points are on the end of a straight line with 
the common end point for the two curves in the middle. Intaglio automatically 
keeps this line straight by moving the control points together to ensure that the 
transition between these two curves is smooth. Sometimes you want the 
transition between two curves to be abrupt rather than smooth. To break the 
straight line, and thus the smooth connection between the curves, place the 
cursor over a control point, hold down the option key on the keyboard, and 
move the control point. This control point will now move independently of the 
opposite control point.

To change an abrupt transition between two curves back to a smooth transition, 
place the cursor over the common end point, hold down the option key on the 
keyboard, and drag the mouse to create new control points.

Paths can also contain arcs. To add an arc to a path, create a new path 
containing the arc using the Arc tool and join the two paths into one by choosing 
Object > Paths > Join. You may have to reverse the arc's path to get it to join on 
the end you want by selecting the arc and choosing Object > Paths > Reverse.

Drawing With Intaglio
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For example, the path below is an arc connected to two straight line segments:

Once you've create a path, you can edit the points in the path using the Point 
Selection tool (see page 17).  The behavior of this tool is very similar to this 
description.  To use the Path tool again with an existing path, select the path 
with the Point Selection tool, hold down the option key on the keyboard, and 
click or drag one of the path's end points. You can now add new points to the 
end of the path with the Path tool.

Filling paths
When you specify a fill color for a path, the interior of that path is painted with 
the color (which might be a solid color, gradient, or pattern—see page 15).  For 
most paths it’s easy to tell where its interior is, but for more complex paths this 
isn’t always so obvious.  For example suppose you want to create a path with a 
hole in the middle like a doughnut.  For this you need a way to fill some parts of 
the path and leave other parts unfilled.  Intaglio uses two different fill techniques 
to decide what the inside a path is, and thus what area will be filled.  These fill 
modes are called Standard and Even/Odd.  You can specify a path’s fill mode 
with the Fill inspector by selecting the path, choosing Window > Fill, and 
selecting the button for the fill mode you wish to use.

Drawing With Intaglio
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The two fill modes differ only in the way they decide where the inside of a path is 
when the path contains segments that overlap.  The even/odd method 
considers an area to be inside a path if you’ve had to cross an odd number of 
path segments to get to it.  The standard method considers an area to be inside 
a path if you’ve crossed more clockwise segments than you have counter-
clockwise segments or vice-versa (in technical circles this is called the non-zero 
winding rule).  For example consider the inside of the following star shaped 
path.  Since the star is a series of lines connected in a clockwise direction the 
entire star is filled using the standard fill mode, however because the inner most 
part of the star is within two lines (an even number) it isn’t filled when using the 
even/odd fill mode.

Standard Even/Odd

Fill Modes

Intaglio generally uses the standard fill mode and you can usually ignore this 
setting unless you have a specific need for the even/odd fill behavior.  For a 
further explanation about how to take advantage of fill modes read about 
compound paths in the next section.

Path operations
If you want to create complex shapes it is sometimes useful to combine two or 
more paths to create a single more sophisticated path.  A compound path is a 
single path made up of two or more separate sections.  For example, the ring in 
the image below is a single path made up of two circles.  The arrows have been 
added in this image to illustrate the direction of each circle.  Since this path is 
using the standard fill mode (see the previous section for an explanation of fill 
modes) and the circles are defined in opposite directions the center of the ring is 
unfilled.

A compound path with clockwise and counter-clockwise segments.
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To create a compound path select two or more paths and choose Object > Paths 
> Combine.  To break a compound path back into separate paths select the 
compound path and choose Object > Paths > Separate.  To reverse the direction of 
a path that will be a section of a compound path (such as the inner circle in the 
image above) select that path a choose Object > Paths > Reverse before you 
create the compound path.

Another way to combine paths to create complex paths is with the path 
operation commands in the Object > Paths menu.

Original

Unite Intersect Exclude Subtract

Unite
The edges of resulting path consist of the outer edges of all the original paths 
combined.

Intersect
The resulting path consists of the area where all the original paths overlap.

Exclude
The resulting path consists of the area where the original paths overlap an odd 
number of times.

Subtract
The resulting path consists of the area occupied by the rear-most original path 
but no other.
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Drawing text
You can create and edit text blocks using the Text tool in the tool palette (see 
page 5):




To create a new text block choose the text tool in the Tool palette, click the 
mouse in the drawing where you want the text, and start typing.  To edit existing 
text choose the Text tool and click the mouse on the text block you wish to edit.  
A short cut to create a new text block is to click the mouse at the point in the 
drawing where you want text, hit the return key on the keyboard, and start 
typing the new text.  If you select an object in the drawing and hit the return key 
the new text block will be centered over the object you selected, unless that 
object is a text block.  In that case you’ll just start editing the text in the block.

Text flow
When you select a text block a small triangle appears with the selection handles 
on the right side of the text block near the bottom.  You can drag this handle to 
adjust the text flow width of the block graphically.  Adjusting this value changes 
the location where a line of text wraps around to the next line.  You can also 
adjust this value numerically in the Text inspector (choose Window > Text).

    

Font features
The menu item Text > Font Features contains a submenu that changes to reflect 
the features available in the currently active font.  Not all fonts have added 
features but some have several.  A few fonts such as Apple Chancery and 
Hoefler Text have many features. Typical features include ligatures and other 
special characters, letter case (e.g., small caps), number styles, and vertical 
position. The features listed in the menu are grouped by category.  If you hold 
the cursor over a menu item, the name of the category will appear in a tip 
window next to the menu.
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Font variations
Font variations are properties built into some fonts, such as Multiple Master 
fonts.  Typical variations include Width (e.g., narrow to wide characters) and 
Weight (e.g., light to heavy characters). To set a variation in a text block or range 
of text, first select the variation in the popup menu in the Text inspector, then 
select the value of that variation using the corresponding slider control.

WAVE WAVE
Light & Narrow Heavy & Wide

Kerning
Kerning is the space between adjacent characters on a line. Kern values can be 
applied to an entire text block or a character range within a text block.

WAVE Tight Kerning

WAVE

WAVE

Normal Kerning

Loose Kerning

Leading
Leading adjustment changes the space between lines of text.  This can only be 
applied to an entire text block.

The quick brown 
fox jumps over 
the lazy dog.

The quick brown 

fox jumps over 

the lazy dog.
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Baseline
Baseline adjustment moves the base of the characters perpendicular to the line.  
Since most lines of text are horizontal the baseline adjustment typically moves 
text vertically.  This can be applied to an entire text block, but it generally most 
useful to apply it to characters within the block.  In the example below, the 
subscript was created by moving the baseline of the zero down and the 
superscript was created by moving the baseline of the exponent up.

m = m0e
-!t

Line direction
Line Direction is an infrequently used property that can be applied to text blocks 
only via AppleScript. This is a property of a text block that may override the 
default system line direction (e.g., right to left vs. left to right).  For example, the 
Arabic and Hebrew languages use a right to left writing system.  Intaglio comes 
with sample scripts to set the line direction.  You can add these scripts to the 
script menu (Intaglio > Scripts) for easier access.

Text as a graphic element
From a graphic point of view, text is normally just filled with a solid color but you 
can use virtually all of the path treatments described in the previous section on a 
block of text.  These include gradient fills and stroke options to create outlined 
text.  You can even use the stroke dash and brush options on a text block.  
There are a few situations where a path is more useful than a text block.  For 
example, you can edit the shape of a path but you can only change the 
characters and font of text.  In these cases, you can convert a text block into a 
path by choosing Object > Convert > Text To Path.  This will usually create a 
compound path so you may want to then break the character shapes out into 
individual paths by choosing Object > Paths > Separate.

Drawing With Intaglio
 28



Binding text to a path
Text normally follows a straight baseline, however you can bind a block of text to 
follow the outline of any path by selecting both the text block and path and 
choosing Text > Path Binding > Bind Text To Path.  Now the text inspector changes 
to allow you to adjust the text’s location in relation to the path.  For example, 
you can adjust the Path Bias slider to set where the text starts on the path and 
select Reverse to put the text inside the path instead of outside it.  You can also 
choose to see the path or make it invisible.

Vertical text
To create vertical text select the text block and choose Text > Vertical.  This 
rotates each character so that it appears to be laying on its side.  Normally you’ll 
then want to rotate the text block -90 degrees by choosing Object > Rotate.  The 
image below shows the text block before and after rotation.

Vertical text before rotation

Vertical text after rotation
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Groups and Masks
One of the basic elements in any drawing application is the object group.  A 
group is just a collection of multiple graphics that are treated as if they were a 
single graphic object.  To create a group select two or more graphics and 
choose Object > Group.  To remove the graphics from a group select the group 
and choose Object > Ungroup.

The Group inspector allows you to perform several advanced graphic functions 
on a group.  To open the group inspector choose Window > Group.

You can set the opacity of a group independently from the opacity of the group’s 
elements.  The elements of a composite group are drawn separately before any 
group properties are applied.  For example, in the image below the three circles 
are grouped.  The group on the left is 100% opaque, but the other two groups 
are partially transparent so you can see the gray bar through them.  However the 
group on the right is a composited group so you only see the gray bar through 
the group.  You don’t see green and red circles through the blue circle in the 
composited group the way you do in the non-composited group.

Another powerful property of a group is the ability to have a mask element.  The 
elements of a masked group are only visible inside one of the group’s elements 
(i.e., the mask).  For example, in the image below the transparent ellipse and the 
text block are grouped and the ellipse is used to mask the text.  Notice how the 
text doesn’t appear anywhere outside of the ellipse.
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The usual behavior of a masked group is to make the top element in the group 
invisible but use it to mask all the other elements.  You can also choose the 
Mask Under option in the Group inspector.  In this case the bottom element of 
the group is used to mask the group but in this case the mask element remains 
visible.  For example, in the image below the group is masked by the red 
rectangle at the bottom but the rectangle is still drawn.

The area that is visible in a masked group is determined by where the interior of 
the masking element is.  This is similar to setting a fill color for the object except 
instead of drawing a color, Intaglio draws the group.  An Intensity mask uses a 
slightly different technique to draw the group.  The lighter an area of the masking 
element is, the lighter the masked group will be drawn in that area.  Where the 
masking element is dark the group will be drawn at full intensity, but where the 
masking element is lighter the group will be correspondingly lighter.

WAVE WAVE
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Gradients
Gradients can be used to fill or stroke paths and text blocks. Three steps are 
required to add a gradient to a graphic.

• First, select the graphic and choose Window > Fill or Window > Stroke to open 
the Fill or Stroke inspector, ensure the style isn't "None" in the inspector, and 
click the mouse in the inspector’s color well to activate the fill or stroke attribute.

•
Second, create the gradient. Choose Window > Gradient to open the Gradient 
inspector and create a new gradient with the colors and other characteristics 
you desire. This gradient will automatically be applied to the fill or stroke of the 
selected graphic depending on which color well you selected in the first step.

• Third, you can optionally set the start and end points of the gradient for the 
graphic. While the graphic is still selected, choose the Gradient tool in the Tool 
palette (see page 5) and drag a line defining the gradient points for the graphic.




Note that if you're setting the gradient points for more than one graphic the 
gradient will blend together where these graphics overlap.

There are two types of gradients, linear and radial.  A linear gradient uses the 
first color at the start point and changes along a straight line to the end point.  A 
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radial gradient uses the first color at the start point and changes along the 
radius of a circle to the end point. In other words, the gradient forms a circle 
whose center is at the start point and whose outer edge is at the end point.

Linear Gradient Radial Gradient

Patterns
Patterns are small drawings which are drawn repeatedly, side by side to form a 
tiled image where each tile is a copy of the original pattern.  To open the Pattern 
inspector choose Window > Pattern.

Unlike some older drawing applications, Intaglio patterns are complete vector 
drawings rather than just small bitmap images.  Therefore a pattern can contain 
virtually any kind of graphics (including small bitmap images).

You use the standard drawing tools to create the pattern in the panel on the right 
side of the inspector. You can also copy graphics from a standard drawing and 
paste them into the pattern, create an entire pattern by dragging graphics into a 
color well, or choose Object > Convert > To Pattern to create a new pattern from the 
graphics currently selected in a drawing.
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Intaglio provides several predefined vector patterns in the fill and stroke pattern 
menus in the toolbar.  These patterns are all supplied in black and white, but it’s 
easy to apply other colors to them in the Pattern inspector.  You can also use the 
Pattern inspector’s drawing capabilities to customize them in other ways, such 
as changing the scale.

A pattern can have an optional background color.  When a pattern is drawn, any 
background color is drawn behind all other pattern graphics.  If a pattern 
doesn’t have a background color areas where there aren’t any graphics will be 
transparent when the pattern is drawn.  The background color is specified by 
the check box and corresponding color well in the Pattern inspector.  The 
Pattern inspector also contains a foreground color well.  Unlike the background 
color, the foreground color isn’t actually a property of the pattern itself.  The 
Pattern inspector fills the foreground color well with the fill color of the graphics 
in the pattern.  If the graphics don’t use a fill color the inspector uses the stroke 
color and if the graphics don’t use a stroke color either (e.g., the pattern graphic 
is a bitmap image), the foreground color is set to black.  The foreground color 
well makes it easy to set the fill or stroke color of all the graphics in a pattern.  
When you change this color, your change is automatically applied to the entire 
pattern.

Choose the Properties button in the Pattern inspector to edit the pattern 
properties.  Pattern properties include the size of the pattern and the distance to 
step after drawing each pattern tile. You can also select tiling options, opacity, 
and whether or not to transform the pattern when the graphic it is attached to is 
transformed (i.e., moved, scaled, etc.)
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When you’ve finished creating the pattern you can drag it from the color well in 
the Pattern inspector to other color wells in Intaglio, or to the Library or Finder 
(see page 7).  The Extras folder included with Intaglio includes a collection of 
sample patterns saved as clipping files.  These patterns contain small bitmap 
images similar to patterns used by older drawing applications.  To use these 
patterns drag a clipping file directly from the Finder into Intaglio.

Styles
Intaglio maintains a set of default properties for each drawing document (e.g., 
line thickness, color, etc.). When you draw something new it is initially given 
these default attributes. The default attributes are set when you change an 
attribute value without first selecting any graphics. For example, if you start with 
a new blank document, set the line thickness to five points, and draw a couple 
lines they will both be five points thick because you have set the document's 
default thickness to that value. If you deselect the lines, set the line thickness to 
ten points and draw a rectangle, it will be ten points thick but the lines will stay 
at five.

Intaglio allows you to create multiple named sets of document defaults called 
styles. If a named style is activated it will be assigned to any new graphics 
created and any later changes to that style will passed on to those graphics. If a 
named style is activated when existing graphics are selected, it will be assigned 
to the selected graphics which will be given the style's attributes. You change 
the attributes of the active style by choosing new values with no graphics 
selected, just as in the behavior above, but when you change the attributes of a 
style those changes are passed on to all graphics that use that style.

In the example above, if you created a named style before initially setting the line 
thickness to five, that style's thickness would be set to five and the lines would 
use that style. Then when you deselected the lines and changed the thickness 
to ten the style thickness would be changed so the lines would change too 
(unless you switched styles first).

To create a new style choose Edit > Styles > New Style and specify the style’s 
name.  To set the style of one or more graphics, select those graphics and 
choose the style you wish to set from the Edit > Styles menu.
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Using Effects

As discussed earlier, Intaglio is vector drawing software.  This means the shapes 
you draw remain shapes internally and are only converted to bitmaps when they 
need to be drawn to the screen or printed page.  This has many advantages but 
some images are best represented by bitmaps earlier in the process.  Intaglio 
bridges these two worlds by allowing you to specify special bitmap effects to be 
performed on standard vector graphic objects.  For example, a soft drop 
shadow such as the ones you see under all the windows in Mac OS X is 
generally a transparent bitmap that becomes lighter as it get further from the 
edges of the graphic.  In comparison, a hard drop shadow for the image below 
would just be a gray circle behind the graphic.  A hard shadow can be created 
by simply drawing a gray circle, but a soft shadow requires a bitmap image to 
be created from the circle with a special blur function (specifically a gaussian 
blur) applied to the bitmap.

Intaglio allows a list of Effects to be applied to any graphic object.  Each effect 
converts the original graphic into a bitmap image while performing special 
processing on the image.  However the original vector graphic isn’t changed and 
can be edited later causing a new series of special effect image operations to be 
performed.  The type of special processing performed in each case will vary with 
the effect selected.  For example, a drop shadow effect gives the appearance of 
an object standing above the page, but an interior shadow effect gives the 
appearance of an object recessed into the page.  Effects can also be chained 
together to allow one effect to provide further processing on the results of the 
previous effect.

Since effects require the original vector graphics to be converted to bitmaps, 
Intaglio uses the drawing’s resolution (see page 9) to determine the size of the 
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bitmaps to create. It's important to note that the vector graphics remain editable 
when effects are used, but the effect bitmaps must be recreated whenever a 
graphic is edited. Since this can be time consuming on slower machines or at 
high resolutions, you may want to temporarily reduce the quality of the effects 
you see on the screen while you’re editing the graphics.  There are two ways to 
reduce this computation time while editing. The first is to hide all effects by 
choosing Layout > Hide Effects, and the second is to ask Intaglio to display effects 
at low resolution on the screen.  To do this choose Layout > Resolution and select 
Preview Effects At Low Resolution.  This will cause effects to be rendered at 72 
dots per inch on the screen, but at full resolution when printing or exporting the 
drawing as an image.

To add effects to a graphic, select the graphic, choose Window > Effects to open 
the Effects inspector, and select an effect from the Add ( + ) popup menu in the 
inspector.

The Effects inspector lists all the effects in the currently selected graphic and 
allows you to edit those effects. The effects are listed from top to bottom, so the 
image above shows a 3D Lighting effect to be drawn over a Drop Shadow 
effect. The items in the list can be dragged to rearrange the effects.

To edit an individual effect, select it in the list on the left side of the inspector 
panel and adjust the controls on the right.  To remove an effect from a graphic, 
select the effect in the list and choose the Delete ( – ) button under the list.

Using Effects
 37



CoreImage effects
CoreImage is an innovative graphics technology in Mac OS X 10.4 to use 
today's advanced graphics cards for image processing. Intaglio allows you to 
use CoreImage to create effects limited only by your graphic hardware and your 
imagination. Computers with less capable video cards are able to use many 
CoreImage features, but performance is slower and experience indicates that 
some features behave in unpredictable ways.

CoreImage includes many different image processing filters called image units. 
To use these filters you must first enable them in the Add ( + ) menu by choosing 
Effects Action > Show Advanced Effects (where Effects Action is the popup menu 
attached to the button in the Effects inspector with a gear icon.)
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The Add ( + ) menu now lists all of the available CoreImage filters by category.

The CoreImage sample below shows one graphic used as a source for another. 
A “light ball” image is mapped onto a 3D surface generated from a text block. 
The light ball is a plain bitmap image in the drawing and presents several light 
sources. This effect also includes two drop shadows (at the top of the list) to 
emphasize the green and red lights on the ball. The list in the Effects inspector 
window shows the filters used to create this effect. As described above, the 
filters at the bottom of the list are performed before those above them in the list. 
This means the filters at the top of the list are drawn on top of the filters below 
them in the list. Filters can be dragged in the list to reorder them.
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Each filter has an output and zero or more inputs (i.e., sources). Frequently as in 
this example, multiple filters are chained together by connecting the output of 
the first to the input of the second, and so on. A filter source can be the output 
of a previous filter (including “generator” filters) or a graphic in the drawing 
previously added to the source list by choosing Effects Action > Add To Source List 
(in the “gear” menu).  In this example the Shaded Material filter uses the light ball 
graphic as its Shading Image input.

Intaglio provides several output channels to contain the intermediate results of a 
filter chain.  These results are saved temporarily to be used as the inputs of 
filters later in the chain.  Here the output of the Shaded Material filter is stored in 
channel A, then used as the input of both Drop Shadow filters. The outputs of 
the two Drop Shadow filters are composited together to form the final image.
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The diagram below shows the chain of filters used in the image above and the 
intermediate results throughout the process. The filters in the effects list above 
are shown in the right column of the diagram.

Source Graphic
CoreImage 

Effects

Color Invert!

Mask To Alpha!

Height Field From Mask

Shaded Material

Drop Shadow (green)!

Drop Shadow (red)

Composite

Channel A

Automatic

Automatic

Lightball

Final Result
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Below a Circle Splash Distortion filter has been composited prior to the drop 
shadows and darkened with a Gamma Adjust filter. Note the drop shadows 
don't change because they're also using the intermediate result of the Shaded 
Material filter as their inputs. The results of all the filters above Shaded Material 
are composited together to form the final image.

To experiment with images similar to those above open the sample drawing 
CoreImage Effects included with Intaglio.
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Creating Slideshows

Intaglio includes basic slideshow presentation capabilities.  Although it’s not 
intended to replace full featured presentation software, such as Apple Keynote™ 
or Microsoft PowerPoint®, Intaglio can be used for basic presentations.

During a slideshow the layers (see page 12) in a drawing are used as individual 
slides.  A slideshow starts using the bottom layer of a drawing as the first slide 
and advances upward through the layers until it reaches the top layer (i.e., the 
last slide).  After reaching the last slide the slideshow either stops and waits for 
the mouse to be clicked, ends, or loops back to the first slide and begins again.  
You can press the escape (i.e., esc) key on the keyboard any time during a 
slideshow to end it immediately.

Normally each layer is a separate slide, but layers can also be set to act as 
master slides.  A master slide isn’t shown as an individual slide on its own, 
instead it appears with every slide in the presentation.  Typically the bottom layer 
is used as a master slide to provide the background for all the other slides in the 
presentation.  In the Layer Settings window below a layer has been configured 
as a master slide (note the checkbox above the OK button).

Once you’ve created a multi-layer drawing choose File > Play Slideshow to start a 
full-screen presentation.  This opens the Slideshow window to allow you to set 
the slideshow options (you can hold down the option key on the keyboard to 
skip this step).

The following options are available for slideshows:
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Scale To Fit Display
Scales slides to fill as much of the presentation display as possible.

Use Secondary Display
Uses the largest display connected to the computer, other than the main display, 
for the presentation.

Hide Master Slides Above
Hides any master slides in layers above the current slide.

Advance...
Automatically advance to the next slide after the specified number of seconds 
have passed.

Loop
After the last slide loop back to the first slide and begin again.

Click Closes Last Slide
End the slideshow when the mouse is clicked in the last slide.

Omit Invisible Layers
Skip any slides made from layers whose visible attribute is turned off.

Transition
Selects an optional transition between slides such as Fade or Dissolve.
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Exchanging Graphics With Other 
Applications

Occasionally you may create graphics from scratch in Intaglio and view or print 
them directly. More often you're likely to build upon graphic elements imported 
from another source and deliver your creation to yet another application to be 
included in a larger document or web site. Therefore it's important to be able to 
import and export graphics to and from other applications while retaining as 
much of the original as possible.

Intaglio can both import and export graphics in PDF and SVG formats and 
export a wide variety of bitmap formats.  To exchange graphics via disk files 
choose File > Import and File > Save As. To transfer graphics directly between 
applications you can use either copy and paste or drag and drop. To use drag 
and drop to import graphics into Intaglio, simply drag the graphic object or file 
into a drawing window. To export graphics via drag and drop, click on the 
graphic and hold the mouse button down for 3/4 of a second before dragging, 
or hold down both the option and command keys on the keyboard as you click 
on the graphic.  If you wish, this delay before drag can be adjusted (or 
eliminated completely) in the Tools panel of the Preferences window.

When exporting bitmap graphics Intaglio will always use the document's export 
resolution (see page 9). For larger, higher quality images choose higher 
resolutions. It's worth noting that effects and some gradient fills are also 
exported as bitmaps and also use the document's export resolution.

The Clipboard panel in the Preferences window (Intaglio > Preferences) contains a 
variety of options to control how graphics are imported and exported (via both 
copy and paste and drag and drop). The Conversions preference panel contains 
options to control graphic conversions from other formats to Intaglio graphics.

PDF (Portable Document Format)
The preferred graphics exchange format for Mac OS X is PDF. Quartz was 
designed specifically to work hand in hand with PDF graphics so this will 
generally give you the best fidelity between applications. For this reason it's best 
to use PDF whenever possible to exchange graphics. Most applications written 
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for Mac OS X include good support for PDF but there are some notable 
exceptions (e.g., Microsoft Word) where bitmap graphics are generally your best 
choice.

A very powerful feature of Intaglio is the ability to convert PDF to editable 
graphics. This means with Intaglio you can edit graphics created in virtually any 
Mac OS X native application. In most cases the properties of elements such as 
text and graphic paths remain available for change. By default Intaglio retains 
PDF graphics intact when importing and you can convert them for editing at any 
time. This conversion can be set to happen automatically when a PDF is 
imported in the Conversions panel of the Preferences window.

SVG (Scalable Vector Graphics)
SVG is a standard graphics format created by W3C, the organization that sets 
standards for the World Wide Web. For this reason SVG is being adopted by 
several web browsers as a way to embed scalable graphics in web sites. 
Because SVG is a vector graphics format it is capable of providing graphics at 
whatever resolution the user needs.

Intaglio is able to export drawings as SVG files and open basic SVG files as new 
drawings. This allows Intaglio to exchange graphics with other SVG enabled 
graphics applications such as open source projects.

iWork
Apple's Pages and Keynote applications are excellent examples of the power of 
Quartz and PDF. For that reason they're also great to use with Intaglio. Intaglio 
graphics can be dragged directly into an iWork document without any loss of 
quality (remember to hold down the mouse button for 3/4 of a second before 
dragging). Furthermore because Intaglio can edit graphics in PDF, you can copy 
an iWork graphic into Intaglio, edit it and return the updated graphic to iWork 
quickly and easily.

To most easily work with graphics from iWork set the following preferences in 
the Conversions panel of the Preferences window (Intaglio > Preferences):
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• Turn on Convert PDF For Editing During Import.
This will automatically convert the iWork PDF into editable graphics when you 
drag or paste it into Intaglio.

• Turn off Convert Clipping Paths.
This will eliminate extra masking groups iWork inserts into the PDF as clipping 
paths. If your iWork graphic contains gradient or image fills you may want to 
leave this option on. This will preserve the correct masking behavior but will 
also result in some extra groups in the conversion. Some Keynote themes use 
image fills to produce a textured appearance that also rely on clipping paths.

• Turn off Convert Transparent Paths.
This will eliminate extra paths iWork inserts into the PDF.

Converting QuickDraw Graphics to Quartz
The original Macintosh provided a graphics system called QuickDraw.  This was 
used by classic Mac applications such as MacDraw and ClarisDraw to build 
their graphics.  Mac OS X introduced a more capable graphics system called 
Quartz.  Intaglio achieves much of its power by using the Quartz graphics in 
Mac OS X, but this makes it more difficult to use older images created with 
QuickDraw based applications.  To make use of legacy graphics files from 
QuickDraw based applications Intaglio is capable of converting vector Picture 
(i.e., PICT) files to Quartz graphics for editing in Intaglio.  Intaglio can also open 
native MacDraw II, MacDraw Pro, and ClarisDraw files directly and convert their 
contents to Quartz.

Intaglio can treat vector QuickDraw pictures (i.e., PICT) created in classic 
Macintosh applications in three different ways.  First they can be converted to 
bitmap images with QuickDraw, this will render them exactly as they originally 
appeared, but the resolution will be fixed and the graphics can't be edited.  
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Second they can rendered with Quartz, this will maintain most of the original 
appearance and add some Quartz features such as anti-aliasing (i.e., it will 
remove the "jaggies"), but the pictures still can't be edited.  Finally, QuickDraw 
pictures can be converted to Quartz graphics allowing them to be edited, but 
this may introduce various artifacts due to the differences between QuickDraw 
and Quartz.

The following issues arise when converting QuickDraw pictures for editing, due 
to various ways in which Quartz differs from QuickDraw.  Options in the 
Conversions pane of the Preferences window allow some choice in how these 
issues are handled.

• QuickDraw strokes (i.e., outlines) graphics with a square pen that can differ in 
width and height.  Therefore the thickness of a QuickDraw line varies with its 
angle.  Converted lines can use the average pen size or attempt to 
compensate for this difference by either setting the stroke width based on the 
line's angle or by creating two graphics to represent the original fill and outline 
respectively.  The line caps (i.e., the style of the end of a line) will also vary due 
to the ways QuickDraw and Quartz each draw lines.

Before: After:

pen size averaged pen size NOT averaged

Before: After:

pen size averaged pen size NOT averaged!

(rear path shifted to show detail)
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• QuickDraw’s transfer modes don't have an analog in Quartz and are ignored.  
Some of the transfer modes are copy, or, and (sometimes called bic), and xor 
(i.e., exclusive or).  These modes change the appearance of a graphic based 
on what is behind it.  In some cases, ignoring the transfer mode causes a 
graphic to change its appearance or even become visible where it was 
originally invisible.

and
xor

Before: After:

• The QuickDraw text style outline and shadow also have no analog in Quartz 
and are ignored.  In Intaglio, outline text can be created by setting the 
appropriate stroke options for the text block.  Text can be given a shadow 
using Intaglio’s effects capabilities (see page 36).

Outline & Shadow

Before: After:

• QuickDraw and Quartz fill arcs differently.  If an arc is both filled and stroked 
the visual appearance can be maintained by converting it to two separate 
paths for the fill and stroke respectively, or it can be combined as a single path 
that fills differently than the original.

Before: After:

two separate paths one combined path
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• QuickDraw patterns were sometimes used to simulate a solid color an older 
computer wasn't capable of displaying by combining colors the computer 
could display.  Modern computers generally don’t have these limitations so 
Intaglio can either maintain patterns as they are presented or convert them to 
solid colors.

pattern maintained pattern averaged

• When text is saved in a QuickDraw picture each separate line and style run 
within a line is saved as a separate text element.  Intaglio attempts to 
reconstruct the original text block from these pieces but this process isn't 
perfect.  Sometimes a single text element may be spread across multiple 
Intaglio text blocks or multiple text elements may be combined incorrectly.  
The Text Element Combination slider the Conversions panel of the Preferences 
window allows some control over this process.

• Most ClarisDraw files can be converted to Intaglio drawings by simply 
choosing File > Open or dropping the file on the Intaglio icon in the dock. A few 
files contain elements not supported by Intaglio, and therefore can't be 
converted.  In this case you can save the file in PICT format within ClarisDraw, 
import that file into Intaglio and convert it for editing.
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Scripting Intaglio

All graphic operations in Intaglio can be performed via AppleScript.  In addition, 
any graphic operation performed within Intaglio is recorded as a script. This 
means you don't have to remember the exact syntax for any particular 
operation, you can just turn on recording in AppleScript and perform the 
operation in Intaglio to get a script that will perform that operation again.  If you 
wish you can modify your new script to perform a slightly different operation or 
repeat it several times.

Scripts can be executed directly from within Intaglio and can be added to the 
script menu (Intaglio > Scripts) for easy access.  The script menu can also be 
added to the toolbar.

Tips and tricks
• If you don't know how to express something you want to do in AppleScript 

turn on recording in the Script Editor and perform a similar operation in 
Intaglio.  Your actions will be translated into a new script in the Script Editor 
that you can adjust to perform exactly what you want it to do.

• AppleScript defines the term "move" to mean "change the order" of an object.  
For example, "move the last graphic to the beginning" will bring the rearmost 
graphic of the current document to the front of all graphics in that document.  
Intaglio uses the term "translate" to mean "change the location" of an object.  
For example, "translate the first path by {20.0, 0.0}" will shift the location of the 
front-most path 20 points to the right.

• When recording a script, Intaglio refers to objects by a unique ID rather than by 
other means such as the object's order. This allows Intaglio to always keep 
track of a specific object even if that object moves, but it also means the script 
created will only run if that object continues to exist.  For example when 
recording, you might get the script "set stroke width of graphic id 1 of 
document id 1 to 10.0". Note this refers to a graphic and a document both 
having an ID of one. This script will only set the stroke width of the first graphic 
created in the first document opened when running Intaglio. If that document 
is closed or the first graphic in it is deleted the script will fail. For more 
flexibility you could modify this script to read "set the stroke width of path 1 to 

Using Effects
 51



10" which would set the stroke width of the front-most path of the current 
document.

• There are several infrequently used settings in Intaglio that can only be 
accessed by running a script.  Example scripts for many of these settings are 
provided in the Samples folder included with Intaglio.  If you require regular 
access to some of these settings, consider adding the script to the script 
menu for easy access.
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